Message: Debug Windows build of G4 9.4.p03 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Debug Windows build of G4 9.4.p03 

Forum: Installation and Configuration
Date: 01 Feb, 2012
From: <heather@slac.stanford.edu>

Hi,

I work on Fermi, and we are moving to Geant4 9.4.p03. Typically, I build using the cygwin instructions - this time around we required a debug version of the static libs for Visual Studio 9 (2008). In the past when working with Visual Studio 2003, using the cygwin build was just fine. This time around we seem to have trouble when building our own code against the new G4 in debug mode with VS 2008, as it seems that the non-debug version of the C run time libraries are being linked into G4 - due to the use of the /MD flag (versus /MDd)? Is there a reason why the G4 debug build has the non-debug flag on?

For fun - I tried out the cmake route (and I have to save I love it) - but I see that the resulting project files also set /MD rather than /MDd when in debug mode. I'm inclined to try a build with /MDd set instead - but it seems prudent to ask if there is a reason not to use the debug version of the C runtime.

Thanks, Heather

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: Debug Windows build of G4 9.4.p03   (Gabriele Cosmo - 02 Feb, 2012)
 Add Message Add Message
to: "Debug Windows build of G4 9.4.p03"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]