Message: Re: Problem building geant4.9.5.b01 with Qt using CMake Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Agree Re: Problem building geant4.9.5.b01 with Qt using CMake 

Forum: Installation and Configuration
Re: Question Problem building geant4.9.5.b01 with Qt using CMake (Zach Hartwig)
Re: Feedback Re: Problem building geant4.9.5.b01 with Qt using CMake (Ben Morgan)
Date: 18 Jul, 2011
From: Zach Hartwig <Zach Hartwig>

Hi Ben,

Setting QTHOME to point to the top-level non-standard Qt directory now allows all Qt-dependent Geant4 code to compile and link successfully. Many thanks.

A minor question: I have several scripts that I use often which depend on the G4INSTALL environmental variable, which formerly pointed to the top-level Geant4 directory (i.e., the first directory available after unpacking the geant4.X.X.tgz source code). I notice that CMake configure script sets this variable to point to (for example on my machine):

  G4INSTALL=/home/hartwig/scratch/geant4/geant4.9.5.b01/share/Geant4-9.5.0

While this is inconvenient, it's certainly not a show-stopper. I was just curous if this was by design and other environmental variables will depend on this value for G4INSTALL (Doesn't seem to be the case but you never know)? Or if I can modify this environmental variable to point where I want it to without breaking anything.

Thanks for your help.

~ZSH

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Note: Re: Problem building geant4.9.5.b01 with Qt using CMake   (Ben Morgan - 18 Jul, 2011)
(_ Ok: Re: Problem building geant4.9.5.b01 with Qt using CMake   (Zach Hartwig - 18 Jul, 2011)
 Add Message Add Message
to: "Re: Problem building geant4.9.5.b01 with Qt using CMake"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]