Message: Re: cmake on Mac OS X and DYLD_LIBRARY_PATH (bug?) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

News Re: cmake on Mac OS X and DYLD_LIBRARY_PATH (bug?) 

Forum: Installation and Configuration
Re: Warning cmake on Mac OS X and DYLD_LIBRARY_PATH (bug?) (Mojca Miklavec)
Date: 15 Jul, 2011
From: Ben Morgan <Ben Morgan>

Hi Mojca

> However the second approach results in:
> 
> > otool -L exampleN02
> exampleN02:
>     libG4Tree.dylib (compatibility version 0.0.0, current version 0.0.0)
>     ...
>     libG4zlib.dylib (compatibility version 0.0.0, current version 0.0.0)
>     /System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility version 1.0.0, current 
>     ... (and everything else the same)
> 
> This means that I cannot run the resulting binary without explicitly setting DYLD_LIBRARY_PATH which is bad. There is a workaround, so I can live with that, but this should probably be fixed.
>

Apologies, this is due to a stupid type in one of our CMake modules, reported as Bug 1231 so will be fixed. There're also details in that report on the trivial patch to fix this.

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: cmake on Mac OS X and DYLD_LIBRARY_PATH (bug?)   (Mojca Miklavec - 18 Jul, 2011)
 Add Message Add Message
to: "Re: cmake on Mac OS X and DYLD_LIBRARY_PATH (bug?)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]