Message: Re: Installing Qt with geant4.9.4 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Installing Qt with geant4.9.4 

Forum: Installation and Configuration
Re: Question Installing Qt with geant4.9.4 (Manuel Castro Avila)
Re: Question Re: Installing Qt with geant4.9.4 (Garnier Laurent)
Date: 04 Jul, 2011
From: Manuel Castro Avila <Manuel Castro Avila>

Hi everyone,

I solved my problem. I was using an old example of Geant 4 from 2008 and it did not have some libraries to compile with Qt, so, I needed to add some libraries like G4UIExecutive.hh in the main.cc file and rewrite some instructions in main.cc, after that, the executable worked by opening the Qt graphic window.

Thanks Laurent for your suggestions.

Cheers,

Manuel

On Mon, 04 Jul 2011 14:08:25 GMT, garnier wrote:

> Hi Manuel,
> 
> In what case does the graphic appear (after it was empty) ? Could you
> give us your vis.mac file ?
> 
> The link to the tutorial you give is not up to date, moreover it was
> host on an user home page in my mab, the good link for the tutorial is
> host on geant.fr : http://geant4.in2p3.fr/spip.php?article60&lang=en (http://geant4.in2p3.fr/spip.php?article60&amp;lang=en)
> 
> Cheers, Laurent
> 
> On Wed, 29 Jun 2011 21:08:52 GMT, Manuel Castro Avila wrote:
> 
> > Hi everyone,
> > 
> > I am trying to install the Qt interface and Qt drivers with Geant4. So,
> > I answered yes in:
> > 
> > Enable building of User Interface (UI) modules? [y]
> > Enable building of the Qt UI module? [y]
> > Enable building of visualization drivers? [y]
> > Enable building of the X11 OpenGL visualization driver? [y]
> > Enable building of the FukuiRenderer/DAWN visualization driver? [y]
> > Enable building of the X11 RayTracer visualization driver? [y]
> > Enable building of the VRML visualization driver? [y]
> > Enable building of the Qt OpenGL visualization driver? [y]
> > Enable internal zlib compression for HepRep visualization? [y]
> > 
> > and I got the variables G4UI_ and G4VIS_.
> > 
> > when I want to run some example, I set:
> > G4UI_BUILD_QT_SESSION=1
> > G4UI_USE_TCSH=0
> > G4UI_USE_QT=1
> > 
> > and
> > G4VIS_USE_OPENGLQT=1
> > G4VIS_BUILD_OPENGLQT_DRIVER=1
> > 
> > The other G4VIS variables are setting to be zero.
> > 
> > Into my vis.mac file, I put:
> > /vis/open OGLSQt or /vis/open OGLIQt
> > 
> > and when I run the example's executable, don't appear a empty graphic
> > window. I am using the instructions avaliable in:
> > 
> > https://users.lal.in2p3.fr/garnier/G4QtTutorial.html#UI
> > 
> > Any can help me?
> > 
> > Thanks in advance.
> > 
> > Manuel
> > 
> 

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Installing Qt with geant4.9.4   (satendra kumar chauhan - 03 Apr, 2013)
 Add Message Add Message
to: "Re: Installing Qt with geant4.9.4"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]