Message: Re: linking error on Red Hat Linux 8 64bit Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: linking error on Red Hat Linux 8 64bit 

Forum: Installation and Configuration
Re: Question linking error on Red Hat Linux 8 64bit (Richard Gillham Darnley)
Re: None Re: linking error on Red Hat Linux 8 64bit (Ben Morgan)
Re: None Re: linking error on Red Hat Linux 8 64bit (Richard Gillham Darnley)
Date: 16 Mar, 2011
From: Ben Morgan <Ben Morgan>

Hi Richard,

Apologies for the delay in getting back to you on this.

On Mon, 14 Mar 2011 17:56:24 GMT, Richard Gillham Darnley wrote:
> Hi,
> 
> Yes it is RedHat 8 (not Fedora 8), here are the sequence of command I
> typed (up to your suggestion of 'make CPPVERBOSE=1'):
>
> ...snip... 
lay2.mac display.mac GNUmakefile_orig sd-slab
> sh-3.2$ make CPPVERBOSE=1
> /home/rvd/geant4/geant4.9.3.p02/config/architecture.gmk:322:
> /home/rvd/geant4/geant4.9.3.p02/config/sys/Linux-g++.gmk: No such file
> or directory
> make: *** No rule to make target
> `/home/rvd/geant4/geant4.9.3.p02/config/sys/Linux-g++.gmk'. Stop.
> ################################################################################
> 

Hmm, this is odd. It looks like your environment is correctly configured, and certainly architecture.gmk is present. You clearly had a working (in the sense of getting to the stage of compiling!) build in your previous post, so I'm not sure what's changed.

I only have a couple of suggestions:

  • Try running just make without the CPPVERBOSE=1. Does it start to compile, giving the original error, or do you get the problem reported above? I don't think this is the issue, but we want to make sure.
  • Is /home/rvd/geant4/geant4.9.3.p02/config/sys/Linux-g++.gmk actually present and if so does it have the correct permissions?
  • Is LDFLAGS set in your environment?

Cheers,

Ben

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: linking error on Red Hat Linux 8 64bit   (Richard Gillham Darnley - 16 Mar, 2011)
1 None: Re: linking error on Red Hat Linux 8 64bit   (Richard Gillham Darnley - 16 Mar, 2011)
2 None: Re: linking error on Red Hat Linux 8 64bit   (Ben Morgan - 16 Mar, 2011)
1 Feedback: Re: linking error on Red Hat Linux 8 64bit   (Richard Gillham Darnley - 16 Mar, 2011)
... 1 Message(s)
 Add Message Add Message
to: "Re: linking error on Red Hat Linux 8 64bit"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]