Message: Re: AIDA and histogram output Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: AIDA and histogram output 

Forum: Installation and Configuration
Re: Question AIDA and histogram output (JohnnyK)
Re: None Re: AIDA and histogram output (Guy Barrand)
Date: 15 Feb, 2011
From: JohnnyK <JohnnyK>

Thank you for responding, I still can't make it work though.

I first ran the example with G4 only, it then compiles the cc.-files and I get an exe-file but the prompt ends with: "Compiling TestEm12.cc // TestEm12.cc//Using global libraries//Linking TestEm12//LINK: warning LNK4044: unrecognized option '/link'; ignored // ... Done!"

So it makes an exe-file and I can run it with my macro, not sure if it's running correctly because of the error-message...

Then I use DOS and call osc_batch/.../setup.bat followed by Cygwin. I use "source C:/G.../env.sh" is this the correct syntax for source setup??

I build and run the example, (the prompt gives me the same output as before: "... warning LNK4044... Done!"). It seems to run correctly and doesn't give me any error-messages.

I switch on the G4ANALYSIS_USE := true in the GNUmakefile and it compiles but when I attempt to run it with my macro it stops at "---> Begin of event: 0". The lines above it states: "BatchLab::TreeFactory::create_tree : unknown type k // HistoManager::book() : problem creating the AIDA tree with storeName = Bragg.hbook storeType = hbook readOnly = 0 createNew = 1"

So it jumps me back to the prompt and I get no output.

Any thoughts on what has gone wrong? perhaps I should try reinstalling G4 and starting over but I'd rather not.

Thanks again, J

 Add Message Add Message
to: "Re: AIDA and histogram output"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]