Message: Re: Geant4 and ROOT versions incompatible? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Geant4 and ROOT versions incompatible? 

Forum: Installation and Configuration
Re: Question Geant4 and ROOT versions incompatible? (Lukas Schulte)
Date: 29 Nov, 2010
From: Michael H. Kelsey <Michael H. Kelsey>

The GEANT4 Toolkit as such has no dependence on ROOT. Several of the examples, and many user applications, include ROOT dependences in their executables to support producing histogram and N-tuple files which are comfortable for the high-energy physics community.

On Mon, 29 Nov 2010 16:16:58 GMT, Lukas Schulte wrote:

> I'm trying to run the latest G4 version (4.9.3.p02) with ROOT 5.26.00
> (64 bit) directly, no AIDA or anything.
> 
> So I added
> 
> CPPFLAGS += -I$(ROOTSYS)/include
> 
> EXTRALIBS = $(shell root-config --glibs)
> 
> in my makefile and made a single histogram as described in thread #187
> of the analysis category for a first try.

This is correct. Do you have $(ROOTSYS)/lib included in your LD_LIBRARY_PATH setting? I presume you must, since |ld| (below) finds _some_ set of ROOT libraries. Are you sure that the ROOTSYS value is consistent in your sessions (for example, do you reset it in your .cshrc or .bashrc)?

> But when I try to compile, I get this error message:
> 
> /usr/bin/ld: skipping incompatible /opt/root-5.26.00_64/lib/libCore.so
> when searching for -lCore

Are you sure that you are running on a 64-bit machine when you do your build? I ran into this problem myself, when I pointed my ROOTSYS to a 64-bit version, but did my building on a 32-bit machine.

      -- Michael Kelsey

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: Geant4 and ROOT versions incompatible?   (Lukas Schulte - 30 Nov, 2010)
 Add Message Add Message
to: "Re: Geant4 and ROOT versions incompatible?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]