Message: Re: Error in running example A01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Error in running example A01 

Forum: Installation and Configuration
Re: None Error in running example A01 (Fahmida khanam)
Date: 06 Nov, 2010
From: Michael H. Kelsey <Michael H. Kelsey>

On Sat, 06 Nov 2010 15:48:43 GMT, Fahmida khanam wrote:
> I have recently installed GEANT4.9.3.p01 in my new macbook pro i5. The
> installation finished without any error message. But when I tried to run
> the example A01, I got this error:
> 
> Linking A01app ld: library not found for -lG4detector collect2: ld
> returned 1 exit status make: ***
> [/Users/fumi/g4work/bin/Darwin-g++/A01app] Error 1

Did you remember to |source env.csh| or |. env.sh| from your G4 installation directory, in the same process where you did the A01 build? You have to have all the G4 environment variables defined, and you have to have DYLD_LIBRARY_PATH set, when you do the application build.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Error in running example A01   (Fahmida khanam - 06 Nov, 2010)
(_ None: Re: Error in running example A01   (Mike Kelsey - 06 Nov, 2010)
(_ None: Re: Error in running example A01   (Fahmida khanam - 06 Nov, 2010)
(_ None: Re: Error in running example A01   (Mike Kelsey - 06 Nov, 2010)
(_ None: Re: Error in running example A01   (Fahmida khanam - 07 Nov, 2010)
(_ None: Re: Error in running example A01   (Mike Kelsey - 07 Nov, 2010)
 Add Message Add Message
to: "Re: Error in running example A01"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]