Message: Re: Installation Problems Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Installation Problems 

Forum: Installation and Configuration
Re: None Installation Problems (Matthew Gignac)
Re: None Re: Installation Problems (Michael H. Kelsey)
Date: 20 Oct, 2010
From: Matthew Gignac <Matthew Gignac>

Hello,

Thank you for your response,

When I run ./Configure -build, here is the syntax I get from the terminal... it is fairly lengthly,

   --- Geant4 Toolkit Build  ---

Would you like to see the instructions? [n] n

Definition of G4SYSTEM variable is Darwin-g++. That stands for:

1) OS : Darwin

2) Compiler : g++

To modify default settings, select number above (e.g. 2) [Press [Enter] for default settings]

There exists a config.sh file. Shall I use it to set the defaults? [y] Fetching default answers from your old config.sh file...

I can set things up so that your shell scripts and binaries are more portable, at what may be a noticable cost in performance. In particular, if you ask to be portable, the following happens:

     1) Shell scripts will rely on the PATH variable rather than using
	the paths derived above.
     2) ~username interpretations will be done at run time rather than
	by Configure.

Do you expect to run these scripts and binaries on multiple machines? [n]

*OPTIONS FOR GEANT4 INSTALLATION PATHS* What is the path to the Geant4 source tree? [/Users/matthewgignac/geant4.9.3.p01]

Where should Geant4 be installed? [/Users/matthewgignac/geant4.9.3.p01]

Do you want to install all Geant4 headers in one directory? [n]

*GEANT4 LIBRARY BUILD OPTIONS* Do you want to build shared libraries? [y] Do you want to build static libraries too? [n] Do you want to build global libraries? [y] Do you want to build granular libraries as well? [n] Do you want to build libraries with debugging information? [n]

*CHECKS AND OPTIONS FOR GEANT4 PHYSICS DATA FILES* Specify the path where the Geant4 data libraries are installed: [/Users/matthewgignac/geant4.9.3.p01/data] checking for PhotonEvaporation2.0... no checking for RadioactiveDecay3.2... no checking for G4EMLOW6.9... no checking for G4NDL3.13... no checking for G4ABLA3.0... no checking for RealSurface1.0... no

Failed to locate one or more of the Geant4 data libraries in

/Users/matthewgignac/geant4.9.3.p01/data

Please enter
1) Another path to search in
2) 'f' to force the use of the path you entered previously (the data libraries
   are NOT needed to build Geant4, but are needed to run applications later).
3) 'c' to customize the data paths, e.g. if you have the data libraries
   installed in different locations.
[f] f

*CHECKS FOR CORRECT MAKE IMPLEMENTATION* Checking for make... /usr/bin/make Checking for gmake... no Checking if make is GNU make... yes

*CHECKS FOR REQUIRED EXTERNAL PACKAGE CLHEP* checking for a CLHEP installation... /Users/matthewgignac/CLHEP

Is this the CLHEP installation you want to use? [/Users/matthewgignac/CLHEP]

You can customize paths and library name of you CLHEP installation:

1) CLHEP_INCLUDE_DIR: /Users/matthewgignac/CLHEP/include 2) CLHEP_LIB_DIR: /Users/matthewgignac/CLHEP/lib 3) CLHEP_LIB: CLHEP To modify default settings, select number above (e.g. 2) [Press [Enter] for default settings]

*OPTIONS FOR GEANT4 USER INTERFACE MODULES* Enable building of User Interface (UI) modules? [y] Enable building of the XAW (X11 Athena Widget set) UI module? [n] Enable building of the X11-Motif (Xm) UI module? [n] Enable building of the Qt UI module? [n]

*OPTIONS FOR GEANT4 VISUALIZATION DRIVERS* Enable building of visualization drivers? [y] Enable building of the X11 OpenGL visualization driver? [n] y Enable building of the X11-Motif OpenGL visualization driver? [n] Enable building of the FukuiRenderer/DAWN visualization driver? [n] Enable building of the X11 OpenInventor visualization driver? [n] Enable building of the X11 RayTracer visualization driver? [n] y Enable building of the VRML visualization driver? [n]

*OPTIONS FOR GEANT4 OPTIONAL EXTENSION MODULES* Enable the Geometry Description Markup Language (GDML) module? [n] Enable build of the g3tog4 utility module? [n] Enable internal zlib compression for HepRep visualization? [n]

End of configuration phase.

Creating configuration setup file...

WARNING: the generated configuration file can be edited if necessary! You can introduce any change to the configuration file /Users/matthewgignac/geant4.9.3.p01/.config/bin/Darwin-g++/config.sh before the final installation. To do so, use a shell escape now (e.g. !vi /Users/matthewgignac/geant4.9.3.p01/.config/bin/Darwin-g++/config.sh).

Press [Enter] to start installation or use a shell escape to edit config.sh:

Can't find config.sh. Can't find config.sh. Can't find config.sh. Can't find config.sh.

WARNING: Geant4 is NOT installed yet! You (or the administrator if you have not enough privileges) should start with $G4INSTALL/Configure -install (where $G4INSTALL is Geant4 install directory).

As for privileges, it is my own personal Macbook, so I don't think I have any problems with that. When I try to run the the input for the Terminal that you provided it doesn't work. I get the same warning message as above.

Your help is greatly appreciated,

Cheers, Matthew

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Installation Problems   (Michael H. Kelsey - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Matthew Gignac - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Mike Kelsey - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Matthew Gignac - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Matthew Gignac - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Mike Kelsey - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Matthew Gignac - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Mike Kelsey - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Matthew Gignac - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Mike Kelsey - 20 Oct, 2010)
(_ Ok: Re: Installation Problems   (Matthew Gignac - 20 Oct, 2010)
(_ None: Re: Installation Problems   (Mike Kelsey - 20 Oct, 2010)
 Add Message Add Message
to: "Re: Installation Problems"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]