Message: G4OpenGLXViewer problem on Ubuntu 10 LTS Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None G4OpenGLXViewer problem on Ubuntu 10 LTS 

Forum: Installation and Configuration
Date: 27 Sep, 2010
From: Valentin Kozlov <Valentin Kozlov>

Good day,

We recently updated our Linux machine to Ubuntu 10 LTS. Compinlation of Geant4.9.1.p01 + CLHEP2.0.4.2 (version previously installed) goes well (though with few tricks), as well as more recent Geant4.9.3.p02 + CLHEP2.0.4.5. In both cases ./Configure -build is used and OpenGLX, OpenGLXM, DAWN, RayTracer , VRML are choosen. I can compile the examples of both installations but while executing (e.g. N03 or N07) I get same error:

G4OpenGLXViewer::G4OpenGLXViewer: unable to get a single buffer visual
G4OpenGLXViewer::G4OpenGLXViewer: unable to get a double buffer visual
G4OpenGLXViewer::G4OpenGLXViewer: unable to get required visuals
... Segmentation fault

Sometimes also core file is produced. Doing '$gdb exampleN07 core' yields at the end:

...
Core was generated by `./exampleN07'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007ffca56fdde4 in G4VisManager::CreateViewer(G4String, G4String) ()
   from /kalinka/software/cern/geant4/geant4.9.2.p01/lib/Linux-g++/libG4vis_management.so

To access the Linux machine either Xming or NXclient is used, glxgears runs well for both remote sessions.

Best regards, Valentin

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: G4OpenGLXViewer problem on Ubuntu 10 LTS   (Joseph Perl - 05 Oct, 2010)
 Add Message Add Message
to: "G4OpenGLXViewer problem on Ubuntu 10 LTS"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]