Message: Re: Geant4 on Sparc and i386 [SOLVED] Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Geant4 on Sparc and i386 [SOLVED] 

Forum: Installation and Configuration
Re: Question Geant4 on Sparc and i386 (David Clark)
Date: 02 Sep, 2010
From: David Clark <David Clark>

Incase anyone is ever interested I have managed to fix the problem and now have a fully working build on Solaris Sparc and i386. By default Solaris uses libCstd for the standard library. This does not include many of the templates needed for Geant4. Instead you can build against the stlport library that is also included with the compiler by adding -library=stlport4 to the CXXFLAGS. This Removes many of the errors above. However, there will be many more errors related to the namespace of math functions used. These are trivial but time consuming to fix.

You must build CLHEP and Geant4 with the stlport4 library.

If anyone has any questions I'd be more than happy to help.

Dave

 Add Message Add Message
to: "Re: Geant4 on Sparc and i386 [SOLVED]"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]