Message: Re: libG4Tree.so load error Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: libG4Tree.so load error 

Forum: Installation and Configuration
Re: Question libG4Tree.so load error (hemiao)
Date: 03 Aug, 2010
From: Michael H. Kelsey <Michael H. Kelsey>

On Tue, 03 Aug 2010 06:45:50 GMT, hemiao wrote:
> I install Geant4.9.3.p01 on fedora 5. first update gcc4.1.1 to gcc4.1.2
> then install clhep2.0.4.5 then install Geant4.9.3.p01 everything goes
> well but when I run examples in the Geant4.9.3.p01,( /novice/n03 ) error
> message as follow: --------------------------------- error messge
> ----------------------------------
> /home/geant4.9.3.p01/lib/Linux-g++/libG4Tree.so: undefined reference to
> `G4VSceneHandler::EstablishSpecials(G4PhysicalVolumeModel&)' collect2:
> ld returned 1 exit status gmake: ***
> [/home/geant4/bin/Linux-g++/exampleN03] Error 1
> --------------------------------- error messge
> ----------------------------------
> 
> what's wrong with installation? I can find libG4Tree.so in the folder of
> ~/geant4.9.3.p01/lib/Linux-g++/

This is a build error. It's finding the library (so you do have LD_LIBRARY_PATH set, presumably after |source $G4INSTALL/env.csh|). However, the build is not complete, probably because something is missing from your environment.

Did you build your G4 installation with visualization tools? In your environment (use the |env| or |printenv| command) do you have a "G4VIS_NONE" variable set? That will prevent the visualization stuff from working properly.

-- Michael Kelsey

 Add Message Add Message
to: "Re: libG4Tree.so load error"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]