Message: cannot find -lXi Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None cannot find -lXi 

Forum: Installation and Configuration
Date: 19 Jul, 2010
From: Aatif Imtiaz Butt <Aatif Imtiaz Butt>

Hi On Scientific Linux 5.4 x86_64 (64-bit), I am trying to insalling Geant4 (version 9.3.p01) with CLHEP (2.0.4.5).

If I switch off all vissualization drivers, I end up with successfull installation of Geant4 and execute N01 example as well.

I want to view geometry and tracks produced through OpenGL which means, I have to recompile Geant4 and switch on vissualization drivers. As mentioned on SLAC webpage, I enabled building of the X11 OpenGL visualization driver and X11 RayTracer visualization driver and started re-compiling. It ended up giving me the following errors (infact, it is unable to locate a file).

Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4FR.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4FR.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4visHepRep.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4visHepRep.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4RayTracer.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4RayTracer.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4VRML.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4VRML.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4Tree.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4Tree.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4visXXX.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4visXXX.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4GMocren.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4GMocren.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4gl2ps.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4gl2ps.so] Error 1 Creating shared library /hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4OpenGL.so ... /usr/bin/ld: cannot find -lXi collect2: ld returned 1 exit status gmake[2]: *** [/hepusers/aibutt/geant4/geant4.9.3.p01/lib/Linux-g++/libG4OpenGL.so] Error 1 gmake[1]: *** [granular] Error 2 gmake[1]: Nothing to be done for `liblist'. Libraries installation completed !

############################################################
# It looks like you had errors during Geant4 installation   
# (or interrupted installation)!                                  
# Please check log file:                                          
# /hepusers/aibutt/geant4/geant4.9.3.p01/.config/bin/Linux-g++/g4make.log                                         
############################################################

Please, let me know how can I resolve this problem. A detailed answer is appriciated as I am new to linux environment. Regards Aatif

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: cannot find -lXi   (Ben Morgan - 20 Jul, 2010)
(_ Question: Re: cannot find -lXi {Help About Symbolic Link}   (Aatif Imtiaz Butt - 20 Jul, 2010)
(_ None: Re: cannot find -lXi {Help About Symbolic Link}   (Ben Morgan - 20 Jul, 2010)
 Add Message Add Message
to: "cannot find -lXi"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]