Message: Re: Undefined symbols: Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

More Re: Undefined symbols:  

Forum: Installation and Configuration
Re: Question Undefined symbols: "G4UIXm::G4UIXm(int, char**)" (Neil Fazel)
Re: None Re: Undefined symbols: (Joseph Perl)
Date: 30 Jun, 2010
From: Neil Fazel <Neil Fazel>

On Wed, 30 Jun 2010 18:30:42 GMT, Joseph Perl wrote:
> In my own experience, make clean is not always entirely clean. The most
> thorough way to clean up from a mess is to entirely delete the bin, lib
> and tmp directories.
> 
> You'll want to clean up both your G4 build and your specific
> application.
> 
> If you are trying to use the motif interface, I would have expected you
> to set G4US_USE_XM to 1, not 0.
> 
> In any case, I suggest you use the Configure script to set up your
> environment rather than doing it by hand. Doing it by hand is fine if
> you can make it work, but the Configure script is more reliable.
> 

Thanks. In the session I posted, I first set G4UI_USE_XM to 1 then to 0, to show that neither works.

Regarding the use of the Configure script, I thought that was meant for use when building/rebuilding geant4 itself, not the user code. My understanding is that as long geant4 has been built with G4UI_BUILD_XM_SESSION=1, then G4UI_USE_XM allows you to switch between Xm and tcsh interfaces. Please correct me if I'm wrong.

Neil

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Undefined symbols:   (Joseph Perl - 30 Jun, 2010)
2 None: Re: Undefined symbols:   (John Allison - 30 Jun, 2010)
1 Feedback: Re: Undefined symbols:   (Neil Fazel - 30 Jun, 2010)
(_ None: Re: Undefined symbols:   (John Allison - 30 Jun, 2010)
 Add Message Add Message
to: "Re: Undefined symbols: "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]