Message: Errors in configuration of Geant4 for Linux Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Errors in configuration of Geant4 for Linux 

Forum: Installation and Configuration
Date: 08 Jun, 2010
From: <herogers08@ole.augie.edu>

Hi,

I'm attempting to install Geant4 version 4.9.3 for Linux following the instructions from http://geant4.slac.stanford.edu/tutorial/installation/Geant4.9.3/Linux/Geant4_9_3_Linux_Installation.htm. I've gotten to "Doing the Initial Build" with no problems, but when I try to run the ./Config -build command for the example "data files for low energy electromagnetic processes" the installation fails.

I'm using Ubuntu version 9.04 and CLHEP version 2.0.4.5.

The errors I keep getting are /usr/bin/ld: cannot find -lXmu. There are similar postings on this site for earlier versions of Geant4, but following their example doesn't solve my problems. We've tried soft-linking to the files on the computer but one posting said this shouldn't be this way, so we couldn't figure out what to do instead. It was suggested that having the development package libX11-devel should solve this issue. I have libX11-dev but couldn't find libX11-devel.

How can I fix this issue?

Thanks,

Hannah Rogers

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Errors in configuration of Geant4 for Linux   (Quentin Cherel - 08 Jun, 2010)
 Add Message Add Message
to: "Errors in configuration of Geant4 for Linux"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]