Message: Question concerning HepMC Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Question concerning HepMC 

Forum: Installation and Configuration
Date: 08 Jun, 2010
From: <heather@slac.stanford.edu>

Hi,

We are in the process of upgrading to G4 9.3.p01 and CLHEP 2.0.4.6.  I am trying to understand if there is a need to installed HepMC and/or HepPDT as well.  We have been stuck on an older G4/CLHEP combination, before HepMC and HepPDT were pulled out.  We do not make use of G4's persistency code.  I do notice this comment in:

/event/src/G4EventManager.cc:
#ifdef CLHEP_HepMC         // Temporarly disabled
#include "G4HepMCInterface.hh"
void G4EventManager::ProcessOneEvent(const HepMC::GenEvent* hepmcevt,G4Event* anEvent)


Is that truly temporary?  I ask since I figure we'll likely upgrade G4 before we upgrade CLHEP again in the future and I'd rather we have all the bits installed now.

Thanks,
Heather

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Question concerning HepMC   (Makoto Asai - 10 Jun, 2010)
2 None: Re: Question concerning HepMC   (Makoto Asai - 11 Jun, 2010)
 Add Message Add Message
to: "Question concerning HepMC"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]