Message: Bug(?) in Geant4_9_3_p01 during configuration and building example A01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Bug(?) in Geant4_9_3_p01 during configuration and building example A01 

Forum: Installation and Configuration
Date: 12 May, 2010
From: Richard Gillham Darnley <Richard Gillham Darnley>

Hi all,

I am getting an odd message when I configure my environment and I get a fatal error when I build example A01.  Here is what I did...
 
I have just installed geant4 v.9.3.01 on my WinXP system with cygwin v.1.7 and CLHEP v.2.0.4.5.

To prepare for later work (addition of GRAS and Open Scientist) I have had to change some of the default installation options during the geant4 build. Namely; all header files are now in one directory, I have enabled the GDML module and I have installed xerces-c-3.1.1-x86-windows-vc-9.0.

Following the installation advice given on the SLAC website I then proceeded to check my installation by building example A01.

Here, I encounter two problems:

1) When I configure the environment by typing:

>> export G4WORKDIR=C:/g4work
>> source C:/Geant4/geant4_9_3/env.sh

I get at the end of the expected output:

>> LD_LIBRARY_PATH is set to include CLHEP libraries.
>> NOTE : you should verify that the correct path for the CLHEP library
>>
>> C:/CLHEP/lib
>>
>> is included in the dynamic library search path ahead of any other
>> installations of CLHEP on your system that may be referenced by this
>> path.

2)  I ignored this and then tried building example A01 and at then end of expected list of make/compile source files I got:

>> Compiling A01app.cc ...
>> A01app.cc
>> Using global libraries ...
>> Linking A01app
>> LINK : fatal error LNK1181: cannot open input file 'xerces-c.lib'
>> make: *** [C:/g4work/bin/WIN32-VC/A01app] Error 2

I would greatly appreciate it if someone can help and advise me on how I can proceed. Would it help if I removed GDML/xerces and continued with the default configuration options?

Thanks in advance,

Richard

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: Bug(?) in Geant4_9_3_p01 during configuration and building example A01   (Geng Chao - 20 Apr, 2011)
 Add Message Add Message
to: "Bug(?) in Geant4_9_3_p01 during configuration and building example A01"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]