Message: Bug in Geant4 9.3p01 Configure script Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Sad Bug in Geant4 9.3p01 Configure script 

Forum: Installation and Configuration
Date: 10 May, 2010
From: Tony Johnson <Tony Johnson>

There appears to be a new bug in the Geant4 Configure script with geant4 9.3p01 (and possibly 9.3). In our experiment-specific make files we make use of lines like:

CCFLAGS += `$(G4INSTALL)/Configure -incflags` `$(CLHEP_BASE_DIR)/bin/clhep-config --include`

and

LDFLAGS += `$(G4INSTALL)/Configure -ldflags` `$(G4INSTALL)/Configure -ldlibs` `$(CLHEP_BASE_DIR)/bin/clhep-config --ldflags` `$(CLHEP_BASE_DIR)/bin/clhep-config --libs`

to compile and link with Geant4. This used to work OK with 9.2, but now the output from

${G4INSTALL}/Configure -incflags

is

LD_LIBRARY_PATH is set to include CLHEP and Geant4 libraries. NOTE : you should verify that the correct path for the CLHEP library

/afs/slac.stanford.edu/package/geant4/vol52/clhep/2.0.4.5/rhel4-32/lib

is included in the dynamic library search path ahead of any other installations of CLHEP on your system that may be referenced by this path.

-I/afs/slac.stanford.edu/package/geant4/vol51/geant4.9.3.p01/rhel4-32/include/geant4

which makes it not so easy to extract the relevant last line. There is a -s option but this suppresses all output (including the essential -I... line).

It would be nice if this could be fixed.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 News: Re: Bug in Geant4 9.3p01 Configure script   (Ben Morgan - 11 May, 2010)
 Add Message Add Message
to: "Bug in Geant4 9.3p01 Configure script"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]