Message: Geant4.93 on Mac leoparrd dylib, file is not of required architecture Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Geant4.93 on Mac leoparrd dylib, file is not of required architecture 

Forum: Installation and Configuration
Date: 12 Mar, 2010
From: Rivas Javier <Rivas Javier >

hello everyone,

I installed geant4.03 on mac

##################### On this machine the G4SYSTEM=Darwin-g++ On this machine the G4INSTALL=/Applications/geant4.9.3 On this machine the G4LIB=/Applications/geant4.9.3/lib On this machine the G4LEVELGAMMADATA=/Applications/geant4.9.3/data/PhotonEvaporation2.0 On this machine the G4RADIOACTIVEDATA=/Applications/geant4.9.3/data/RadioactiveDecay3.2 On this machine the G4LEDATA=/Applications/geant4.9.3/data/G4EMLOW6.9 On this machine the G4NEUTRONHPDATA=/Applications/geant4.9.3/data/G4NDL3.13 On this machine the G4ABLADATA=/Applications/geant4.9.3/data/G4ABLA3.0 On this machine the G4REALSURFACEDATA=/Applications/geant4.9.3/data/RealSurface1.0 On this machine the CLHEP_BASE_DIR=/Applications/CLHEP On this machine the CLHEP_INCLUDE_DIR=/Applications/CLHEP/include On this machine the CLHEP_LIB_DIR=/Applications/CLHEP/lib On this machine the CLHEP_LIB=CLHEP On this machine the G4DEBUG=1 On this machine the G4UI_USE_TCSH=1 On this machine the G4VIS_BUILD_OPENGLX_DRIVER=1 On this machine the G4VIS_BUILD_RAYTRACERX_DRIVER=1 On this machine the G4VIS_USE_OPENGLX=1 On this machine the G4VIS_USE_RAYTRACERX=1 On this machine the XMFLAGS= On this machine the XMLIBS= On this machine the XMFLAGS= On this machine the XAWFLAGS= On this machine the XAWLIBS= On this machine the G4LIB_BUILD_SHARED=1

but when i try to run somes codes i get this error Can somebody say me what ist wrong?

/home/javier/geant4.9/tmp/Darwin-g++/Hadrontherapy/libHadrontherapy.dylib, file is not of required architecture

ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4Tree.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4FR.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4GMocren.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4visHepRep.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4RayTracer.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4VRML.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4OpenGL.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4gl2ps.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4vis_management.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4modeling.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4interfaces.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4persistency.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4error_propagation.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4readout.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4physicslists.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4run.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4event.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4tracking.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4parmodels.dylib, file is not of required architecture
ld warning: in /Applications/geant4.9.3/lib/Darwin-g++/libG4processes.dylib, file is not of r#

Best regards,

Javier

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Geant4.93 on Mac leoparrd dylib, file is not of required architecture   (John Allison - 12 Mar, 2010)
 Add Message Add Message
to: "Geant4.93 on Mac leoparrd dylib, file is not of required architecture"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]