Message: Re: Geant4.93 on Mac leoparrd dylib, file is not of required architecture Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Geant4.93 on Mac leoparrd dylib, file is not of required architecture 

Forum: Installation and Configuration
Re: Question Geant4.93 on Mac leoparrd dylib, file is not of required architecture (Rivas Javier )
Date: 13 Mar, 2010
From: Marcus Mendenhall <Marcus Mendenhall>

If all you get are the warnings, you are probably OK. The warnings are a results of some of the files having been built for universal architecture ('fat' libraries), and some others having only one architecture.

As long as the linker finds at least one consistent set of architectures, the code will run. I get these messages when I use my embedded python bindings for Geant4, since the bindings are being linked against the Python executable, which is universal, but the Geant4 libraries are i386 only. It works fine.

Of course, if you can't run, follow John Allison's advice, and rebuild everything to make sure you have current libraries.

Marcus Mendenhall

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Geant4.93 on Mac leoparrd dylib, file is not of required architecture   (Rivas Javier - 14 Mar, 2010)
(_ Note: Re: Geant4.93 on Mac leoparrd dylib, file is not of required architecture   (garnier - 15 Mar, 2010)
(_ None: Re: Geant4.93 on Mac leoparrd dylib, file is not of required architecture   (Rivas Javier - 15 Mar, 2010)
 Add Message Add Message
to: "Re: Geant4.93 on Mac leoparrd dylib, file is not of required architecture"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]