Message: gcc error in 4.9.3 during compilation but run ok Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question gcc error in 4.9.3 during compilation but run ok 

Forum: Installation and Configuration
Date: 12 Feb, 2010
From: Sergio Lo Meo <Sergio Lo Meo>

Hello,

I have installed 4.9.3 and the compilation of CLHEP (2.4.0.5) and geant4 is ok.

I have tested Hadr01 example and it compiles but .. when linking..

/usr/lib/gcc-lib/i486-slackware-linux/3.3.4/../../../../i486-slackware-linux/bin/ld: `.L16664' referenced in section `.rodata' of /usr/local/geant4/geant4.9.3/lib/Linux-g++/libG4hadronic_bert_cascade.a(G4NucleiModel.o): defined in discarded section `.gnu.linkonce.t._ZNK25G4InuclElementaryParticle15getParticleMassEi' of /usr/local/geant4/geant4.9.3/lib/Linux-g++/libG4hadronic_bert_cascade.a(G4NucleiModel.o)

/usr/lib/gcc-lib/i486-slackware-linux/3.3.4/../../../../i486-slackware-linux/bin/ld: `.L1904' referenced in section `.rodata' of /usr/local/geant4/geant4.9.3/lib/Linux-g++/libG4hadronic_bert_cascade.a(G4BigBanger.o): defined in discarded section `.gnu.linkonce.t._ZNK25G4InuclElementaryParticle15getParticleMassEi' of /usr/local/geant4/geant4.9.3/lib/Linux-g++/libG4hadronic_bert_cascade.a(G4BigBanger.o)

and so on... till

/usr/lib/gcc-lib/i486-slackware-linux/3.3.4/../../../../i486-slackware-linux/bin/ld: `.L2253' referenced in section `.rodata' of /usr/local/geant4/geant4.9.3/lib/Linux-g++/libG4had_neu_hp.a(G4NeutronHPContAngularPar.o): defined in discarded section `.gnu.linkonce.t._ZNK23G4NeutronHPInterpolator11InterpolateE21G4InterpolationSchemeddddd' of /usr/local/geant4/geant4.9.3/lib/Linux-g++/libG4had_neu_hp.a(G4NeutronHPContAngularPar.o)

Done!

The problem seem to be for all hadronic library.

Had01 run good, but what is the meaning of these messages during compilation?

where is my error?

I have gcc 3.3.4 on Linux 2.6.24

The same problem is with 4.9.2.p02 CLHEP 2.0.4.2

Thanks

Cheers

Sergio

 Add Message Add Message
to: "gcc error in 4.9.3 during compilation but run ok"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]