Message: Re: Building library management utility liblist produces error Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback Re: Building library management utility liblist produces error 

Forum: Installation and Configuration
Re: Question "Building library management utility liblist" produces error (Andreas Zwerger)
Date: 05 Feb, 2010
From: Gabriele Cosmo <Gabriele Cosmo>

Hi Andreas,

> The first problem I had was g++.exe missing in cygwin /bin folder.
> So I simply copied g++-4.exe to g++.exe in order to have the build process running.
> Maybe this was wrong?
> 
> when I take a look into the makefile it gives me:
> 
> liblist: $(G4LIBDIR)/liblist
> 
> $(G4LIBDIR)/liblist: $(G4INSTALL)/config/liblist.c
>         @$(ECHO) "Building library management utility liblist ..."
>         @if [ ! -d $(G4LIBDIR) ] ; then mkdir $(G4LIBDIR) ;fi
>         @$(CC) $(CCFLAGS) -o $(G4LIBDIR)/liblist $(G4INSTALL)/config/liblist.c
> 
> I couldn't find out where CC or CCFLAGS is defined. Might this be the problem?

there must be something wrong in your CygWin installation, concerning
the gcc compiler. I would suggest you to review that.
You can also try to explicitly set CC to gcc in your environment, although that
should not be necessary if gcc is properly configured within CygWin.

Cheers, Gabriele

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Building library management utility liblist produces error   (Joseph Perl - 05 Feb, 2010)
2 None: Re: Building library management utility liblist produces error   (Andreas Zwerger - 06 Feb, 2010)
1 Ok: Re: Building library management utility liblist produces error   (Andreas Zwerger - 06 Feb, 2010)
 Add Message Add Message
to: "Re: Building library management utility liblist produces error"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]