Message: Re: Qt problem with geant4.9.3 mac os x installation Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

More Re: Qt problem with geant4.9.3 mac os x installation 

Forum: Installation and Configuration
Re: None Qt problem with geant4.9.3 mac os x installation (Olivier Dadoun)
Date: 07 Jan, 2010
From: Garnier Laurent <Garnier Laurent>

Hi,

There is two problems...

First, Configure step has a problem holding "by hand" Qt path on mac OSX. 
In order to do that, you have to patch the Configure file. Around line 2500,
after :
             if test "x\$g4_qt_lib" = "x" ; then
                # We might be on Windows...
                g4_qt_lib="\`ls \$g4_qt_lib_dir/QtCore4.lib 2> /dev/null | sed -n 1p | sed s@\$g4_qt_lib_dir/@@\`"
            fi

Add : 
            if test "x\$g4_qt_lib" = "x" ; then
                # We might be on Mac...
                g4_qt_lib="\`ls \$g4_qt_lib_dir/QtCore* 2> /dev/null | sed -n 1p | sed s@\$g4_qt_lib_dir/@@ |  sed s@[.].*@@\`"
            fi

But that will not solve your problem... :( Because what you will have is a Qt Framework. In order to add your own Framework path, you add to patch a second time Configure, around line 2290 after :
        g4_qt_include_path_list="
            \`ls -dr /Library/Frameworks/QtCore.framework/Headers 2>/dev/null\` 

Add path to YOUR QtCore Framework installation :
            \`ls -dr /usr/local/Qt4.6-64bits....../QtCore.framework/Headers 2>/dev/null\` 

Before Configure file is patch, Anyone has a better solution ?

Laurent

 Add Message Add Message
to: "Re: Qt problem with geant4.9.3 mac os x installation"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]