Message: G4visHepRep problem during G4 installation on Ubuntu Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question G4visHepRep problem during G4 installation on Ubuntu 

Forum: Installation and Configuration
Date: 11 Dec, 2009
From: <Freddie>

Hello all,

I have been attempting to install Geant4.9.1.p03 on an Ubuntu Linux v. 9.10 (Karmic Koala) operating system with the default gcc v4.4.1. (I have attempted to install the later version of Geant4, Geant4.9.2, but it is not compatible with GATE 5.0.0.p01 according to GATE installation error messages I received. Therefore, I defaulted back to the previous version of Geant4)

I have installed LMF v3.0, CHLEP v2.0.4.4, ROOT v5.25.04 (successfully, I think). I have run any checks that were recommended, and used the configuration scripts to setup the environmental variables. When attempting to build Geant4.9.1.p03, however, I get an error message (after many hours of building/compiling) which indicates that there may have been some errors during the process. I have rebuilt "fresh" copies of Geant4.9.1.p03 a few times, but still get the error same message.(I did not receive any such messages when building Geant4.9.2) I have attached the log file. Line # 4316 of the log file indicates that G4visHepRep was not created/compiled correctly:

Compiling DefaultHepRepTypeTree.cc ... Compiling DeflateOutputStreamBuffer.cc ... In file included from src/DeflateOutputStreamBuffer.cc:3: include/cheprep/DeflateOutputStreamBuffer.h:32: error: ‘EOF’ was not declared in this scope make[2]: *** [/home/fdaver/apps/geant4.9.1.p03/tmp/Linux-g++/G4visHepRep/DeflateOutputStreamBuffer.o] Error 1 Making dependency for file src/G4TheRayTracer.cc ... Making dependency for file src/G4RTXScanner.cc ...

Despite the error messages, I have attempted to run a few examples. The first example in ...../novice/N01 seems to run fine. All other examples attempted, however, give me the error message:

/usr/bin/ld: cannot find -lG4visHepRep collect2: ld returned 1 exit status gmake

I have found a thread regarding this issue (please see http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1228/1.html), but the issue was never resolved. I have also installed additional Ubuntu packages mentioned in other forums with similar problems. I have also attempted to compile Geant4 after installing various versions of CLHEP including v2.0.3.2 as well as CLHEP v2.0.4.2 as specified for GATE v5.0 requirements. Regardless of which version I use, I get the same error message when attempting to compile Geant4.

If anyone has suggestions on how to compile G4visHepRep correctly, or information on paths, incompatibilities, etc. it would be appreciated! Thank you!

Sincerely, Freddie

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2009/12/11/11.23-15854-g4make.log

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: G4visHepRep problem during G4 installation on Ubuntu   (Gabriele Cosmo - 14 Dec, 2009)
 Add Message Add Message
to: "G4visHepRep problem during G4 installation on Ubuntu"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]