Message: Can't link in HepRep library Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Can't link in HepRep library 

Forum: Installation and Configuration
Date: 15 Oct, 2009
From: Sean Turnbull <Sean Turnbull>

Hi all,

I have been compiling away using Geant4 normally and suddenly I can't seem to compile my example. I have always been able to before. Something much have changed on my system as my code hasn't. I get:

gmake Using granular libraries ... Linking au-muon /usr/bin/ld: cannot find -lG4visHepRep collect2: ld returned 1 exit status gmake: *** [/home/sturnbull/geant4/work/bin/Linux-g++/au-muon] Error 1

Now ls -l $G4LIB/$G4SYSTEM/libG4visHepRep.so -rwxr-xr-x 1 sturnbull rmit 734623 Sep 8 20:20 /nfs/user1/sturnbull/geant4/lib/Linux-g++/libG4visHepRep.so

so it exists ok. Just recompiled Geant 4.9.2 with patch 2 completely and same error. LD_LIBRARY_PATH contains /nfs/user1/sturnbull/geant4/lib/Linux-g++:

Any ideas? I don't specifically need HepRep in my code or use it at all.

Thanks all.

Sean

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: Can't link in HepRep library   (Ben Morgan - 28 Oct, 2009)
(_ Feedback: Re: Can't link in HepRep library   (Sean Turnbull - 29 Oct, 2009)
1 None: Re: Can't link in HepRep library   (Ben Morgan - 29 Oct, 2009)
1 Feedback: Re: Can't link in HepRep library   (Sean Turnbull - 29 Oct, 2009)
... 2 Message(s)
2 Question: Re: Can't link in HepRep library   (Summit - 29 Mar, 2010)
 Add Message Add Message
to: "Can't link in HepRep library"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]