Message: Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine 

Forum: Installation and Configuration
Date: 21 Sep, 2009
From: <icx719>

Hello, everyone!

Recently I tried to run my Geant4 simulations on a bi-quad-core Intel Xeon server. The installation of Geant4.9.2.p01 was sucessful. However, I found that the new Quad-core machine is surprisingly much slower than our old Xeon server. When Geant4 simulation is running, I noticed that the cpu load is very low, only around 3%, and the CPU status (monitored by top) often indicates "D" - "uninterruptable sleeping". I guess some settings related to multi-core arch. might not be correctly configured. Here are some comparisons:

-------------------------------------------------

New: 2.6.30-gentoo-r4 smp x86_64 Bi-Quad-core Intel Xeon 2.80 Ghz
     Geant4 built for x86_64-pc-linux-gnu

Old: 2.6.24-gentoo-r8 smp i686 intel xeon cpu 2.40 Ghz 
     Geant4 built for i486-pc-linux-gnu

1. examples/novice/N02: 20000 events

   Old:  User=42.97s Real=42.97s Sys=0s
   New:  User=18.6s  Real=18.6s Sys=0s

2. examples/novice/N03: 20000 events

   Old: User=51.42s Real=52.71s Sys=1.28s
   New: User=22.04s Real=175.09s Sys=0.98s

3. my own application: 20000 events

   Old: User=3.1s Real=5.09s Sys=1.99s
   New: User=1.86s Real=175.76s Sys=1.12s

----------------------------------------

Does someone have any idea?

thanks!

Yong

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine   (Paul Nicholas Colin Gloster - 21 Sep, 2009)
1 None: Re: Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine   (icx719 - 21 Sep, 2009)
(_ None: Re: Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine   (Paul Nicholas Colin Gloster - 21 Sep, 2009)
(_ None: Re: Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine   (icx719 - 21 Sep, 2009)
2 Ok: Re: Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine   (icx719 - 25 Sep, 2009)
 Add Message Add Message
to: "Surprisingly poor performance of Geant4.9.2.p01 on a bi-quad-core Intel xeon machine"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]