Message: Re: linux version and OpenGL Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: linux version and OpenGL 

Forum: Installation and Configuration
Re: None linux version and OpenGL (Ritika Garg)
Date: 19 Mar, 2009
From: Ben Morgan <Ben Morgan>

On Thu, 19 Mar 2009 09:44:21 GMT, ritikagarg wrote:
> Can geant4 be installed on the following version of linux:
> 
> Linux version 2.6.24-23-generic ( buildd@vernadsky ) (gcc version 4.2.3
> (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Mon Jan 26 00:13:11 UTC 2009
> 
> What is the command to check if the system that I am working on has
> OpenGL package or not?
> 

The appropriate place to post this question WOULD have been in thread 1182 - PLEASE, PLEASE put the questions related to this problem there, rather than cludging up the forum with all these new threads.

Anyway, firstly you don't specify what Geant4 version you want to install. Assuming it's the latest version, yes, it should be o.k., but you won't know until you try!

You also don't specify the exact system you're running on, but it is Ubuntu Hardy by the looks of things. As I already told you earlier, I think you need

libgl1-mesa-dev

libgl1-mesa-glx

mesa-common-dev

Possibly also

libglu1-mesa-glx

libglu1-mesa-dev

Do 'dpkg -l | grep mesa' to see if these are installed.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: linux version and OpenGL   (Ritika Garg - 20 Mar, 2009)
(_ None: Re: linux version and OpenGL   (Ben Morgan - 20 Mar, 2009)
(_ None: Re: linux version and OpenGL   (Ritika Garg - 24 Mar, 2009)
(_ None: Re: linux version and OpenGL   (Ben Morgan - 24 Mar, 2009)
(_ None: Re: linux version and OpenGL   (Ritika Garg - 30 Mar, 2009)
(_ None: Re: linux version and OpenGL   (Ben Morgan - 30 Mar, 2009)
(_ None: G4files   (Ritika Garg - 01 Apr, 2009)
(_ Question: Re: G4files   (Gabriele Cosmo - 01 Apr, 2009)
(_ None: Re: G4files   (Ritika Garg - 02 Apr, 2009)
 Add Message Add Message
to: "Re: linux version and OpenGL"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]