Message: Re: OpenGL. i know. i know. but still stuck. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: OpenGL. i know. i know. but still stuck. 

Keywords: leopard intel opengl
Forum: Installation and Configuration
Re: None OpenGL. i know. i know. but still stuck. (W.J. Llope)
Re: None Re: OpenGL. i know. i know. but still stuck. (John Allison)
Re: None Re: OpenGL. i know. i know. but still stuck. (W.J. Llope)
Re: None Re: OpenGL. i know. i know. but still stuck. (John Allison)
Date: 30 May, 2008
From: W.J. Llope <llope@physics.rice.edu>

hi again
o.k. - now i'm confused. because i've done all that before. 
and this time it worked.  details below.

> OK. Right. When building Geant4 with "./Configure -build", it says, "On this machine 
> the G4VIS_USE_OPENGLX=1". But that all happens in a sub-shell. It is not permanent. 

i set G4WORKDIR, append to DYLD_LIBRARY_PATH, and source env.csh from my .cshrc

> To get the correct environment fro your application, you have to:
>
>  ./Configure

[snip]
overwrite ./env.csh? (y/n [n]) y
overwrite ./env.sh? (y/n [n]) y
[snip]

>(This makes env.sh and env.csh.)
>  source env.sh (or env.csh if you are using a C-shell)
>(This sets the environment of the current shell.)
>  cd <your application, e.g., geant4/novice/N03>
>  make clean
>  make

[AL:/Applications/geant4.9.1.p02] wjllope% cd ~/geant4/A01
[AL:~/geant4/A01] wjllope% make clean
Cleaning up ...
[AL:~/geant4/A01] wjllope% make
Making dependency for file A01app.cc ...
[snip]
Compiling A01Trajectory.cc ...
Creating/replacing object files in /Users/wjllope/geant4/tmp/Darwin-g++/A01app/libA01app.a ...
ar: creating archive /Users/wjllope/geant4/tmp/Darwin-g++/A01app/libA01app.a
ranlib: file: /Users/wjllope/geant4/tmp/Darwin-g++/A01app/libA01app.a(A01AnalysisManager.o) has no symbols
ranlib: file: /Users/wjllope/geant4/tmp/Darwin-g++/A01app/libA01app.a(A01AnalysisManager.o) has no symbols
Compiling A01app.cc ...
Using granular libraries ...
Linking A01app ...
... Done!
[AL:~/geant4/A01] wjllope% ../bin/Darwin-g++/A01app 

*************************************************************
 Geant4 version Name: geant4-09-01-patch-02    (9-May-2008)
                      Copyright : Geant4 Collaboration
                      Reference : NIM A 506 (2003), 250-303
                            WWW : http://cern.ch/geant4
*************************************************************

Visualization Manager instantiating...
Visualization Manager initialising...
Registering graphics systems...

You have successfully registered the following graphics systems.
Current available graphics systems are:
  ASCIITree (ATree)
  DAWNFILE (DAWNFILE)
  G4HepRep (HepRepXML)
  G4HepRepFile (HepRepFile)
  RayTracer (RayTracer)
  VRML1FILE (VRML1FILE)
  VRML2FILE (VRML2FILE)
  OpenGLImmediateX (OGLIX)
  OpenGLStoredX (OGLSX)
  RayTracerX (RayTracerX)

HEY THERE!

i wish i knew what caused this to start working!  
the best i can figure is that i reinstalled the X11 SDK (can't be sure i installed
that when i installed XCode months ago) and then i recompiled geant4
but i may have neglected to recompile the app. i could swear i did but
maybe not.
is the X11 SDK *required*? if not, something else was going on....

thanks for the comments.... cheers
    bill

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "Re: OpenGL. i know. i know. but still stuck."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]