Message: Re: Link errors under FreeBSD 6.2 with gcc 3.4.6 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

More Re: Link errors under FreeBSD 6.2 with gcc 3.4.6 

Keywords: FreeBSD link error
Forum: Installation and Configuration
Re: Question Link errors under FreeBSD 6.2 with gcc 3.4.6 (Mark Looper)
Date: 02 Apr, 2008
From: Gabriele Cosmo <Gabriele Cosmo>

Hi Mark,

from the error message it looks like you're missing completely the Geant4 libraries
from the link command. Please, verify this by issuing:
  make CPPVERBOSE=1
while building the example.
If that's the case and assuming your setup is indeed OK, it may be eventually due to
a fault in the execution of the tool which prepares the list of granular libraries for
linking or in the system commands (grep, echo, find, ...) involved in such process,
which for some reason fail on FreeBSD 6.2 (have no means to verify that...).
A quick alternative for you is to use a build of Geant4 based on 'global' libraries
on that system.

Cheers, Gabriele

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Link errors under FreeBSD 6.2 with gcc 3.4.6   (Mark Looper - 02 Apr, 2008)
(_ Feedback: Re: Link errors under FreeBSD 6.2 with gcc 3.4.6   (Gabriele Cosmo - 02 Apr, 2008)
(_ Agree: Re: Link errors under FreeBSD 6.2 with gcc 3.4.6   (Mark Looper - 02 Apr, 2008)
 Add Message Add Message
to: "Re: Link errors under FreeBSD 6.2 with gcc 3.4.6"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]