Message: Re: Attempting to install under FreeBSD 6.2 with gcc 3.4.6 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Attempting to install under FreeBSD 6.2 with gcc 3.4.6 

Keywords: FreeBSD compile error
Forum: Installation and Configuration
Re: Question Attempting to install under FreeBSD 6.2 with gcc 3.4.6 (Mark Looper)
Date: 25 Feb, 2008
From: Ben Morgan <Ben Morgan>

Hi Mark,

Looking at the output from the build, the problem occurs in source/GNUmakefile in the libmap target, and it's this section

@$(ECHO) "Making libname.map starter file ..."
@touch /tmp/G4libname.map.starter.$(unique);
@for i in `$(CAT) /tmp/G4_granlib_makefiles.$(unique)`; \
   do \
     $(GREP) '^ *name *:=' $$i | $(CUT) -d \  -f 3 \
     >> /tmp/G4libname.map.starter.$(unique); \
     $(ECHO) $$i | $(SED) "s/^\\./source/" \
     >> /tmp/G4libname.map.starter.$(unique); \
   done
@$(ECHO) "Making libname.map ..."

So I suspect it's the

$(GREP) '^ *name *:=' $$i

that's causing the issue. I'm not familiar with FreeBSD grep, although assuming the error message is trying to be helpful, you could try changing this to

$(GREP) -e '^ *name *:=' $$i

Can't guarantee that'll fix things though...

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: Attempting to install under FreeBSD 6.2 with gcc 3.4.6   (Mark Looper - 29 Feb, 2008)
 Add Message Add Message
to: "Re: Attempting to install under FreeBSD 6.2 with gcc 3.4.6"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]