Message: Geant 4.9.1 viewers on Mac OS Tiger (10.4) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Geant 4.9.1 viewers on Mac OS Tiger (10.4) 

Keywords: Geant4 4.9.1. viewers Tiger Mac OS
Forum: Installation and Configuration
Date: 20 Feb, 2008
From: Angela Lucaci-Timoce <Angela Lucaci-Timoce>

Hello all, I've installed Geant 4.9.1 on a Mac laptop with Tiger (10.4). I can run the examples, but I have problems with the viewers. Although I have the following variables set:

On this machine the G4VIS_BUILD_OPENGLX_DRIVER=1.

On this machine the G4VIS_BUILD_RAYTRACERX_DRIVER=1.

On this machine the G4VIS_BUILD_VRML_DRIVER=1

On this machine the G4VIS_USE_OPENGLX=1

On this machine the G4VIS_USE_RAYTRACERX=1

On this machine the G4VIS_USE_VRML=1

I am not able to use any viewer. For example, doing from an xterm,
/vis/open OGLIX
results in:
G4OpenGLXViewer::G4OpenGLXViewer: unable to get a single buffer visual.
G4OpenGLXViewer::G4OpenGLXViewer: unable to get a double buffer visual.
G4OpenGLXViewer::G4OpenGLXViewer: unable to get required visuals.
G4OpenGLImmediateX::CreateViewer: error flagged by negative view id in G4OpenGLImmediateXViewer creation.
 Destroying view and returning null pointer.
ERROR in G4VisManager::CreateViewer during OpenGLImmediateX viewer creation.
  No action taken.
WARNING: No viewer created.

Does anybody know what I am doing wrong?

Thank you in advance, Angela

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Geant 4.9.1 viewers on Mac OS Tiger (10.4)   (John Allison - 22 Feb, 2008)
 Add Message Add Message
to: "Geant 4.9.1 viewers on Mac OS Tiger (10.4)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]