Message: compiling with gcc 4.1 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question compiling with gcc 4.1 

Forum: Installation and Configuration
Date: 20 Feb, 2008
From: Lynn Garren <garren@fnal.gov>

On our installations of Scientific Linux Fermi 5.x, we have gcc 4.1.2, which comes with gfortran, not g77. There is still a small part of geant4 that requires fortran.

We build manually, and I find no obvious way to set the fortran compiler. I can't just edit config/sys/Linux-g++.gmk because the source code is shared with installations on other platforms which still have g77.

Is there a recommended way to deal with this?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: compiling with gcc 4.1   (Ben Morgan - 21 Feb, 2008)
 Add Message Add Message
to: "compiling with gcc 4.1"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]