Message: Re: Reg: Using Xcode for developing Geant4 Application Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Reg: Using Xcode for developing Geant4 Application 

Forum: Installation and Configuration
Re: None Reg: Using Xcode for developing Geant4 Application
Date: 20 Nov, 2007
From: Olivier Dadoun <Olivier Dadoun>

Hello,

(the following is resume on my web page here: http://dadoun.net/Informatique/macosx.php)
Let try to compile examples/novice/N04 with Xcode
(maybe there is something more easy)
1)Open Xcode (:))
2)Select New Project from file menu and select External Build System
3)Select your project Name: XcodeN04 for example and give
the path where the example is installed 
(for me /Applications/geant4.8.3/examples/novice/N04/)
4)Open the disclosure triangle beside the XcodeN04 (left side) drag the folder 
containing the sources files src (Tell Xcode not to copy files)
5)From the Project Menu choose New Target and select Shell Script Target
 and give a name Xenv.sh (for example) and close the pop up window
6)Open the disclosure triangle beside Xenv.sh and double click on Run Script
7)Add those following line between #shell script... and exit 0 :
# shell script goes here
source $G4INSTALL/env.sh
make
exit 0
(give the full path of $G4INSTALL)
8)From the Project Menu Set Active Target select the name of your script file here Xenv.sh
you can build now
hope it will work

cheers Olivier

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Reg: Using Xcode for developing Geant4 Application   (Michael Burgess - 09 Dec, 2007)
1 None: Re: Reg: Using Xcode for developing Geant4 Application   (Olivier Dadoun - 09 Dec, 2007)
3 None: Re: Reg: Using Xcode for developing Geant4 Application   (fatin hamimi mustafa - 05 Jul, 2013)
1 None: Re: Reg: Using Xcode for developing Geant4 Application   (Olivier Dadoun - 08 Jul, 2013)
 Add Message Add Message
to: "Re: Reg: Using Xcode for developing Geant4 Application"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]