Message: Re: No hits in sensitive detector Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: No hits in sensitive detector 

Forum: Hits, Digitization and Pileup
Re: None No hits in sensitive detector (Christopher Walker)
Re: None Re: No hits in sensitive detector (Makoto Asai)
Date: 28 Nov, 2017
From: Christopher Walker <Christopher Walker>

Hi Makato,
    Thankyou for looking at my code. You were right that I was running in Multi-threaded mode. I have changed the code, but I still seem to have no hits being registered. I think it is possible that my code might be affected by multi-threading effects elsewhere. For instance, I notice the code from my ActionInitialization class:

void ActionInitialization::BuildForMaster() const
{
	// In MT mode, to be clearer, the RunAction class for the master thread might be
	// different than the one used for the workers.
	// This RunAction will be called before and after starting the
	// workers.
	// For more details, please refer to :
	// https://twiki.cern.ch/twiki/bin/view/Geant4/Geant4MTForApplicationDevelopers
	//
	// RunAction* runAction= new RunAction(fDetectorConstruction);
	// SetUserAction(runAction);
}

Hence, I wonder if it might be better to start again from scratch with a functioning example (such as B2a). I suspect that it would better to start with a working Multi-threaded example and then change the Physics, rather than try to get the Multi-threading to work on some code where the Physics model is correct, but the multi-threading is somehow corrupted. Would you agree ?

Thanks Chris

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: No hits in sensitive detector   (Christopher Walker - 29 Nov, 2017)
 Add Message Add Message
to: "Re: No hits in sensitive detector"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]