Message: no hits in Sensitive detector with G4VReplica Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question no hits in Sensitive detector with G4VReplica 

Forum: Hits, Digitization and Pileup
Date: 01 Aug, 2016
From: <jtaylor@hep.ph.liv.ac.uk>

Hi,

I'm trying to create a sensitive detector that that has a 2D pixellated geometry. First I use G4VReplica to create rows (like a strip array) then I attempt to make replica's within these rows to form the pixels.

As far as I know, replicas within replicas should be fine but when I run the simulation there are no hits present in the SD. As far as i can tell this is because the ProcessHits method is never called which I think means no particles cross the logical volume?

In the visualisation, the geometry looks fine and everything compiles and runs correctly with tracks going through the detector. If I run with no pixels enables ie just the rows like a 1D strip array then everything is fine! So there is some problem with the additional layer of replicas but I cannot work out what it is

I have attempted to run:

/geometry/test/run /geometry/test/recursive_test

To check that there are no overlapping volumes, the first executes correctly and reports no errors, the second doesn't seem to work, here is the output:

G4PhysicalVolumeModel::Validate(): A volume of the same name and
  copy number ("World", copy 0) still exists and is being used.
  But it is not the same volume you originally specified
  in /vis/scene/add/.
Running geometry overlaps check...
Checking overlaps for volume Phantom_1 ... OK! 
Checking overlaps for volume DeviceUnderTest_pix1 ... OK! 
Checking overlaps for volume DeviceUnderTest_pix2 ... OK! 
Geometry overlaps check completed !
***** COMMAND NOT FOUND </geometry/test/recursive_test> *****

***** Batch is interrupted!! *****

Any help is greatly appreciated, I have attached my DetectorConstruction and SensitiveDetector classes.

Cheers,

Jon

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/08/01/04.57-13169-DetectorConstruction.cc
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/08/01/04.57-31735-SensitiveDetector_pix.cc

 Add Message Add Message
to: "no hits in Sensitive detector with G4VReplica"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]