Message: RDM producing decay and invalid nucleus error Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question RDM producing decay and invalid nucleus error 

Forum: Hadronic Processes
Date: 10 Jan, 2009
From: Sean Turnbull <Sean Turnbull>

Hello, I am simulating the capture of a neutron in Au using thermal neutrons.

I am using the RDM and it seems to work but I am getting the infamous error:

G4RadioactiveDecay::DecayIt : Au197[0.0] is not a valid nucleus for the RDM
G4RadioactiveDecay::DecayIt : Hg198[0.0] is not a valid nucleus for the RDM

I am getting what I want though.

 ------ Parent Particle ----------
 Particle type - Au198[0.0]
   mass:        184.36634[GeV]
   charge:      79[e]
   Direction x: 0, y: 0, z: 0
   Total Momentum = 0[GeV]
   Momentum: 0[GeV], y: 0[GeV], z: 0[GeV]
   Total Energy   = 184.36634[GeV]
   Kinetic Energy = 0[GeV]
 MagneticMoment  [MeV/T]: 0
   ProperTime     = 0[ns]

I am wondering is there an error in my coding or something else? I am using Geant4.9.2. I have also checked that the variable:

G4RADIOACTIVEDATA=/usr/local/geant4/data/RadioactiveDecay3.2 is pointing to the correct dir.

My Physicslist can be found at http://www.skydiver.dyndns.org:2020/PhysicsList.cc

Thanks!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Note: Re: RDM producing decay and invalid nucleus error   (Fan Lei - 12 Jan, 2009)
 Add Message Add Message
to: "RDM producing decay and invalid nucleus error"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]