Message: Problems with neutron HP and LEND with Argon interactions Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Problems with neutron HP and LEND with Argon interactions 

Forum: Hadronic Processes
Date: 18 Jan, 2018
From: Matthew Blackston <Matthew Blackston>

I am seeing some strange behavior with neutron HP and LEND when I simulate a target of liquid argon. I'm using g4.10.04 and I've done my tests with the Shielding physics list, selecting "HP" and "LEND" models when I instantiate the physics list. When I change the target to iron or carbon I don't see these problems.

Using the HP neutron physics, I find that elastic interactions are happening, but it doesn't change the energy or momentum of the incoming 14 MeV neutron, and no recoil argon nucleus is created. For instance, here is an example of what I see in my sensitive detector class:
     hit #1: 14.1 MeV neutron; time = 12.94 ns; process = hadElastic; momentum = (0,0,1); position = (0,0,-35.4)
     hit #2: 14.1 MeV neutron; time = 15.67 ns; process = Transportation; momentum = (0,0,1); position = (0,0,104.8)
All elastic interactions are like this using HP. It seems to determine that there is an elastic scatter, but doesn't update the neutron or recoil argon.

Using the LEND neutron physics, I find that elastic interactions result in a neutron with kinetic energy of "nan" (not a number), which eventually decays. Here is an example of what I see in my sensitive detector class:
     hit #1: 14.1 MeV neutron; time = 11.95 ns; process = hadElastic; momentum = (0,0,1); position = (0,0,-86.4)
     hit #2: nan eV neutron; time = 1148.67 s; process = Decay; momentum = (0,0,1); position = (0,0,-86.4)
     hit #3: 322.7 keV e-; time = 1148.67 s; process = eIoni; momentum = (0.408,0.748,-0.523), position = (0.1,0.2,-86.6)
     hit #4: 459.6 keV anti_nu_e; time = 1148.67 s; process = Transportation; momentum = (-0.202,-0.375,0,905); position = (-40.8,-75.7,96.5)
     hit #5: 532.9 eV proton; time = 1148.67 s; process = hIoni; momentum = (0.677,0.003,-0.736); position = (0,0,-86.4)
All elastic interactions are like this for LEND.

When I change the material of the target to something else, this problem goes away, though I only tried a few materials. I get the same results with the Shielding physics list as I get when I use my own physics list and call G4HadronElasticPhysicsHP.

Thanks,
Matthew

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Note: Re: Problems with neutron HP and LEND with Argon interactions   (Matthew Blackston - 18 Jan, 2018)
(_ None: Re: Problems with neutron HP and LEND with Argon interactions   (michel maire - 29 Jan, 2018)
(_ Ok: Re: Problems with neutron HP and LEND with Argon interactions   (Matthew Blackston - 30 Jan, 2018)
 Add Message Add Message
to: "Problems with neutron HP and LEND with Argon interactions"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]