Message: issue with 137-Cs decay Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question issue with 137-Cs decay 

Forum: Hadronic Processes
Date: 22 Apr, 2016
From: Alexis Schubert <Alexis Schubert>

Hello,

I'm trying to simulate the decay of 137-Cs to 137-Ba. The 662-keV level of 137-Ba should have a half life of 2.6 minutes, but it seems to decay immediately. I tried the simulation with and without setting G4ENSDFSTATEDATA, but it doesn't seem to change the result. Is there something I'm doing wrong?

In the extended/radioactivedecay/rdecay01 example, I modified src/SteppingVerbose.cc to add a column that displays fTrack->GetLocalTime().

137-Cs decays after several years, as expected:

*********************************************************************************************************
* G4Track Information:   Particle = Cs137,   Track ID = 1,   Parent ID = 0
*********************************************************************************************************

Step#      X         Y         Z        KineE    dEStep   StepLeng  TrakLeng   LocTime    Volume     Process
    0      0 fm      0 fm      0 fm      0 eV      0 eV      0 fm      0 fm      0 ps      World   initStep
    1      0 fm      0 fm      0 fm      0 eV      0 eV      0 fm      0 fm     57 y       World   RadioactiveDecay

    :----- List of secondaries ----------------
   Ba137[661.659]:  energy =0.2967 eV   global time = 56.97 y    local time =     0 ps 
       anti_nu_e:  energy = 274.5 keV  global time = 56.97 y    local time =     0 ps 
              e-:  energy = 239.4 keV  global time = 56.97 y    local time =     0 ps 
    :------------------------------------------

But the 662-keV level of 137-Ba decays immediately:

*********************************************************************************************************
* G4Track Information:   Particle = Ba137[661.659],   Track ID = 2,   Parent ID = 1
*********************************************************************************************************

Step#      X         Y         Z        KineE    dEStep   StepLeng  TrakLeng   LocTime    Volume     Process
    0      0 fm      0 fm      0 fm  0.297 eV      0 eV      0 fm      0 fm      0 ps      World   initStep
    1      0 fm      0 fm      0 fm  0.297 eV  0.297 eV      0 fm      0 fm      0 ps      World   RadioactiveDecay

    :----- List of secondaries ----------------
           Ba137:  energy =0.2967 eV   global time = 56.97 y    local time =     0 ps 
           gamma:  energy = 661.7 keV  global time = 56.97 y    local time =     0 ps 
    :------------------------------------------

I used these commands in a .mac file:

/tracking/verbose 2 /gun/particle ion /gun/ion 55 137 0 0 /run/beamOn 1

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Idea: Re: issue with 137-Cs decay   (L. Althüser - 23 May, 2016)
(_ None: Re: issue with 137-Cs decay   (Alexis Schubert - 23 May, 2016)
 Add Message Add Message
to: "issue with 137-Cs decay"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]