Message: Ion gets a strange boost when emitting gamma ray (G4RadioactiveDecay) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Ion gets a strange boost when emitting gamma ray (G4RadioactiveDecay) 

Forum: Hadronic Processes
Date: 14 Dec, 2012
From: <ljungvall@csnsm.in2p3.fr>

Dear all,

trying to verify that I get physical results when simulating the gamma-decay of excited ions in flight I've stumbled across some problems (search on my name...) and I have another one, trying to understand from where it comes...

Have a look at the following

*********************************************************************************************************
* G4Track Information:   Particle = Os170[2545.2],   Track ID = 1,   Parent ID = 0
*********************************************************************************************************

Step#    X(mm)    Y(mm)    Z(mm) KinE(MeV)  dE(MeV) StepLeng TrackLeng  NextVolume ProcName
    0    0.000    0.000   -1.000    40.000    0.000    0.000     0.000    hallPhys initStep
    1    0.000    0.000   -1.000    40.000    0.000    0.000     0.000    hallPhys RadioactiveDecay
    :----- List of 2ndaries - #SpawnInStep=  2(Rest= 0,Along= 0,Post= 2), #SpawnTotal=  2 ---------------
    :     0.000     0.000    -1.000    72.193      Os170[1945.8]
    :     0.000     0.000    -1.000     0.589              gamma
    :----------------------------------------------------------------- EndOf2ndaries Info ---------------

***********************************************************************

the 170Os gets a 30 MeV boost having emitted a 600 keV gamma... energy crises resolved ? ;)

I've dug a bit and found out that the problem is an inconsistent use of the parameter theDynamicalMass in the class G4ParticleDefinition. It is assumed to be, at most places in the geant4 code m0*c2 (+ Eex for ions) but for the newly created 170Os ion it is set to (I think, my pocket calculator indicated this) gamma*m0*c2. The result is that the nucleus gets a boost in

G4RadioactiveDecay.cc:1586

since theParentEnergy is off...

This is not normal I can not find when theDynamicalMass is set to the wrong value... help is appreciated to understand what is wrong, and if it might be a bug in geant4.9.6 or in my code

I include some logs of a geant4 session and gdb session...

kind regards

Joa

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2012/12/14/02.11-69387-g4logfile.txt
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2012/12/14/02.11-16964-gdblogfile.txt

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Ion gets a strange boost when emitting gamma ray (G4RadioactiveDecay)   (michel maire - 14 Dec, 2012)
2 None: Re: Ion gets a strange boost when emitting gamma ray (G4RadioactiveDecay)   (ljungvall@csnsm.in2p3.fr - 14 Dec, 2012)
 Add Message Add Message
to: "Ion gets a strange boost when emitting gamma ray (G4RadioactiveDecay)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]