Message: Re: Problems with "G4CascadeElasticInterface" Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Problems with "G4CascadeElasticInterface" 

Forum: Hadronic Processes
Re: Question Problems with "G4CascadeElasticInterface"
Date: 05 Jan, 2011
From: Michael H. Kelsey <Michael H. Kelsey>

On Wed, 05 Jan 2011 15:23:34 GMT, HadronTherapy_Aachen wrote:
> I updated my Geant4 version from 9.3.p01 to 9.4. So everything seems to
> be fine, except that I get a compilation error complaining that
> 
> G4CascadeElasticInterface.hh
> 
> cannot be found in my Bertini cascade implementation. Do you have any
> idea about this issue when upgrading to the new version?

Urgh. We (I) conducted an extensive cleanup of the whole Bertini code base last year, which was deployed in 9.4 (not in the 9.3 patches).

G4CascadeElasticInterface was a duplicate version of the "standard" (i.e., used in the production physics lists) G4CascadeInterface. It was left over from a development project started a few years ago and not completed, and it was not referenced in any of the production physics lists or in the distributed G4 examples. Therefore, I removed it, along with a number of similarly duplicate orphan files.

My apologies for causing confusion.

If you are using your own physics list, you should be able to switch to G4CascadeInterface.hh (and "new G4CascadeInterface", of course) with no other changes. However, you are probably better off using one of the production physics lists, such as QGSP_BERT, QGSP_BERT_HP, or QGSP_FTFP_BERT.

-- Michael Kelsey

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: Problems with   (HadronTherapy_Aachen - 06 Jan, 2011)
 Add Message Add Message
to: "Re: Problems with "G4CascadeElasticInterface""

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]