Message: Re: GDML Assembly Won't Load Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: GDML Assembly Won't Load 

Forum: Geometry
Re: Question GDML Assembly Won't Load (Mark McCrea)
Re: None Re: GDML Assembly Won't Load (Tatiana Nikitina)
Re: None Re: GDML Assembly Won't Load (Mark McCrea)
Date: 15 Sep, 2009
From: John Apostolakis <John Apostolakis>

Mark,

You can emulate assemblies, in two ways (at least):
   - Creating a new level of volume (and putting the assembly contents  
inside) - so long as the new volumes do not overlap;
   - Looping over your assembly instances and placing the volumes an  
assembly is composed of.

I realize that the second method introduces complexity into either you  
GDML file or a program that you use to create it.  Unfortunately for  
now this cannot be avoided.

Regards,
John Apostolakis

P.S. By the way, could you let us know of your affiliation and project.

On Sep 15, 2009, at 5:54 PM, Mark McCrea wrote:

>
> *** Discussion title: Geometry
>
> Thanks for you help. I'll start looking for alternative placement
> methods.
>
> Mark McCrea
>
> -------------------------------------------------------------
> Visit this GEANT4 at hypernews.slac.stanford.edu message (to reply  
> or unsubscribe) at:
> http://hypernews.slac.stanford.edu/HyperNews/geant4/get/geometry/986/1/1.html

 Add Message Add Message
to: "Re: GDML Assembly Won't Load"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]