Message: Re: Particle is skipping or stucked in certain region during the tracking Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback Re: Particle is skipping or stucked in certain region during the tracking 

Forum: Geometry
Re: Question Particle is skipping or stucked in certain region during the tracking (Nahee Park)
Date: 05 Feb, 2009
From: Gabriele Cosmo <Gabriele Cosmo>

 Hi Nahee Park,

> The geometry in my simulation is overlapping of ellipsoids. The smallest
> ellipsoid has radius of ~ 37km + radius of the Earth. The biggest
> ellipsoid has radius of ~ 1000 km + radius of the Earth. It would take
> care of the trajectories of particle from altitude of 1000 km to
> altitude of 37km. Total 269 ellipsoids are made (Consecutively smaller
> one is set as a daughter volume of larger one.). Radius difference
> varies from 400 m to 10 km. I also put additional ellipsoid (detection
> layer) at the altitude where I would like to check the properties (which
> is 37 km for this case) - the region belong to the detection layer is 2
> cm height.

 there can be several reasons leading to the problem you observe:
 - overlapping volumes in your geometry [should be fixed];
 - possible shared surfaces among one or more volumes [try to avoid
    them by introducing a tiny gap in your placements];
 - precision issues due to a not properly tuned geometrical tolerance
    [try setting the geometrical tolerance according to your bigger volume
    extent: G4GeometryManager::GetInstance()->SetWorldMaximumExtent(worldExtent);]
 - a bug in the implementation of the solid [see in the problem reporting
    system, you may find already similar open issues, otherwise open a new
    ticket giving all the details necessary to reproduce the problem].

 Hope it helps.
 Cheers, Gabriele

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: Particle is skipping or stucked in certain region during the tracking   (Nahee Park - 05 Feb, 2009)
(_ Feedback: Re: Particle is skipping or stucked in certain region during the tracking   (Gabriele Cosmo - 05 Feb, 2009)
 Add Message Add Message
to: "Re: Particle is skipping or stucked in certain region during the tracking"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]