Message: Re: grid_test behaviour in geant4.9.0.p01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: grid_test behaviour in geant4.9.0.p01 

Keywords: grid_test
Forum: Geometry
Re: Question grid_test behaviour in geant4.9.0.p01 (Gabriel Musat)
Date: 16 Oct, 2007
From: Tatiana Nikitina <Tatiana Nikitina>

 Dear Gabriel,

 You are right, as it shown in your example,
 the volume caloL_P is not outside the mother volume, the problem is in the grid_test. 
 In your case grid coincides with the common border. In this case the algorithm may have a problem.
By placing  box in (50.0*mm,-49.999999*mm,-49.999999*mm) instead of (50,-50,-50) the error message will desappear.  
 The  grid_test was slightly changed in geant4.9.0.p01.
 This changes made 'visible' the problem being here already in 4.8.3.p01.

You can see the problem by moving grid_lines. 
If in your application you do :
 /geometry/test/position 100 -99.999999 -70 mm
 /geometry/test/direction/1 0 0 mm
 /geometry/test/line_test true
You will see the error message in both versions : 8.3 and 9.0 

If you try the same line_test but with position (100,-100, -70 mm) it will give the error only for 4.9.0.p01 version.

If you try the same line_test but with position
 (100,-100.000001, -70 mm) the error will desappear from both versions.

Thank you for reporting the problem. It will be helpful if you could open a bug report.

Best regards, Tatiana Nikitina _

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "Re: grid_test behaviour in geant4.9.0.p01"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]