Message: creating volumes with 'holes' using G4AssemblyVolume Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question creating volumes with 'holes' using G4AssemblyVolume 

Keywords: assembly volume imprints
Forum: Geometry
Date: 25 Jun, 2007
From: Mario <Mario>

I am trying to create a mesh geometry.  I have made an assembly volume with
many smaller logical volumes made of a Nickel material by using the 
AddPlacedVolume method.  After the assembly volume is finished I imprint it
into a different logical volume (whole_vol) made of 'Vacuum' (lowest 
density of air). And then finally use G4VPlacement to place the whole_vol
in the correct place.  Everything compiles, and runs smooth, and the it 
looks correct using the WIRED3 vis.  However, the particles don't seem to 
care if they are going through the mesh substrate or through the holes, they
always think of it as 'Vacuum'... I don't know if I need to do something to
make them notice the logical volumes from the assembly volume imprint. Any
advice would be great!!

Cheers,
Mario

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: creating volumes with 'holes' using G4AssemblyVolume   (Gabriele Cosmo - 26 Jun, 2007)
(_ None: Re: creating volumes with 'holes' using G4AssemblyVolume   (Mario - 26 Jun, 2007)
(_ None: Re: creating volumes with 'holes' using G4AssemblyVolume   (John Apostolakis - 28 Jun, 2007)
(_ None: Re: creating volumes with 'holes' using G4AssemblyVolume   (Mario - 28 Jun, 2007)
 Add Message Add Message
to: "creating volumes with 'holes' using G4AssemblyVolume"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]