Message: Re: Moving the particleGun Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Moving the particleGun 

Forum: Geometry
Re: None Moving the particleGun (Laura)
Re: None Re: Moving the particleGun (Ryan Romero)
Date: 01 Aug, 2006
From: Vladimir IVANTCHENKO <vnivanch@mail.cern.ch>

On Mon, 31 Jul 2006, Ryan Romero wrote:

> *** Discussion title: Geometry
> Email replies to PublicHyperNews@slac.stanford.edu must include:
>   In-Reply-To: <"/geometry/538/3"@geant4-hn.slac.stanford.edu>
>   Subject: ...change this to be about your reply.
> 
> Hi. I'm trying to generate a particle gun that shoots protons. I want to
> shift the source position within the user interface but it isn't
> working. /gun/position 0 0 0 m does'nt seem to work nor does it work
> with other units. /gun/direction does work very well, so I'm thinking i
> might be using /gun/position incorrectly som how.
> 
> I am able to set the position of the gun within the source code, but
> then changing positon will require me to recompile every time.
> 
> Is there something in the code I can change so that the /gun/position
> command will work, or am I'm using this incorrectly?
> 
> Thanks.
> 

Hello in some applications/examples inside PrimaryGeneratorAction some 
parameters like position are hardcoded. In such case UI command, of 
course, has no effect. So, check first PrimaryGeneratorAction of your 
application.

VI

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "Re: Moving the particleGun"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]