Message: Migration from 4.6.1 to 4.7.0 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Migration from 4.6.1 to 4.7.0 

Keywords: geometry geant4.6.1 geant4.7.0
Forum: Geometry
Date: 01 Apr, 2005
From: Andrey Elagin <elagin@nusun.jinr.ru>

Hello,

I have the code below wich is working under geant4.6.1, gcc-2.96 and RedHat7.3.1. I tried to run it with geant4.7.0, gcc-3.2.3 and RedHat7.3.1

it compiles, but crashes after "/run/beamOn":

PANIC! - G4SmartVoxelHeader::BuildNodes()
         Daughter physical volume Calo_Sens_R
         is entirely outside mother logical volume World !!

*** G4Exception : InvalidSetup
      issued by : G4SmartVoxelHeader::BuildNodes()
Overlapping daughter with mother volume.
*** Fatal Exception *** core dump ***

*** G4Exception: Aborting execution *** Aborted

G4Box*           solidWorld = new G4Box("world",20.*cm,20.*cm,500.*cm);
G4LogicalVolume* logWorld = new G4LogicalVolume(solidWorld,Air,"World",0,0,0);
G4VPhysicalVolume* physiWorld = new G4PVPlacement(0,G4ThreeVector(), 
                   logWorld,"World",0,false,0);

G4Box* solidCaloSens = new G4Box("calo_sens",5.*cm,5.*cm,5.*cm);

G4LogicalVolume* logCaloSens_R = new G4LogicalVolume(solidCaloSens,Diamond,
                                 "Calo_sens_R",0,0,0);

G4LogicalVolume* logCaloSens_L = new G4LogicalVolume(solidCaloSens,Diamond,
                                 "Calo_sens_L",0,0,0);

G4VPhysicalVolume* physiCaloSens_R =
  new G4PVPlacement(0, G4ThreeVector(0., 0., 370.*cm),  
  "Calo_Sens_R",logCaloSens_R,physiWorld, false,0);

G4VPhysicalVolume* physiCaloSens_L =
  new G4PVPlacement(0,G4ThreeVector(0.,0.,-370.*cm),"Calo_Sens_L",logCaloSens_L,
                    physiWorld, false,0);

Does anybody know what is wrong?

thank you

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: Migration from 4.6.1 to 4.7.0   (Gabriele Cosmo - 13 Apr, 2005)
 Add Message Add Message
to: "Migration from 4.6.1 to 4.7.0"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]