Message: Failed in creating a polyhedron Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Failed in creating a polyhedron 

Forum: Geometry
Date: 11 Aug, 2014
From: Yuefeng Qiu <Yuefeng Qiu>

Hi !

I tried to create a polyhedron for visualization purpose. The nodes and facets I list here:

            <Nodes lunit="cm"> // the nodes here is redundant 
                <Node x="7.75" y="0.25" z="21.2"/>
                <Node x="7.75" y="-0.25" z="21.2"/>
                <Node x="7.50" y="0.0" z="21.2"/>
                <Node x="7.75" y="0.25" z="21.2"/>
                <Node x="7.75" y="-0.25" z="21.2"/>
                <Node x="7.75" y="-0.25" z="20.57"/>
                <Node x="7.75" y="0.25" z="20.57"/>
                <Node x="7.75" y="-0.25" z="20.57"/>
                <Node x="7.75" y="-0.25" z="21.2"/>
                <Node x="7.50" y="0.0" z="21.2"/>
                <Node x="7.50" y="0.0" z="20.57"/>
                <Node x="7.75" y="0.25" z="21.2"/>
                <Node x="7.75" y="0.25" z="20.57"/>
                <Node x="7.50" y="0.0" z="20.57"/>
                <Node x="7.50" y="0.0" z="21.2"/>
                <Node x="7.50" y="0.0" z="20.57"/>
                <Node x="7.75" y="0.25" z="20.57"/>
                <Node x="7.75" y="-0.25" z="20.57"/>
            </Nodes>
            <Facets>
                <Facet n1="1" n2="3" n3="2"/>
                <Facet n1="6" n2="7" n3="4"/>
                <Facet n1="6" n2="4" n3="5"/>
                <Facet n1="9" n2="10" n3="11"/>
                <Facet n1="9" n2="11" n3="8"/>
                <Facet n1="13" n2="14" n3="15"/>
                <Facet n1="13" n2="15" n3="12"/>
                <Facet n1="18" n2="16" n3="17"/>
            </Facets>

Actually it is just a simple wedge shown in the picture. But it just crash when creating this polyhedron using G4Polyhedron::createPolyhedron.

Is there anyone who can help me to have taste on it?

Many thanks!

Best regards, Yuefeng

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2014/08/11/08.30-5845-Wedge.png

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Failed in creating a polyhedron   (John Allison - 11 Aug, 2014)
(_ None: Re: Failed in creating a polyhedron   (Yuefeng Qiu - 11 Aug, 2014)
(_ None: Re: Failed in creating a polyhedron   (John Allison - 11 Aug, 2014)
(_ None: Re: Failed in creating a polyhedron   (Yuefeng Qiu - 11 Aug, 2014)
(_ None: Re: Failed in creating a polyhedron   (John Allison - 12 Aug, 2014)
(_ None: Re: Failed in creating a polyhedron   (Yuefeng Qiu - 13 Aug, 2014)
1 None: Re: Failed in creating a polyhedron   (John Allison - 13 Aug, 2014)
2 None: Re: Failed in creating a polyhedron   (John Allison - 13 Aug, 2014)
1 Ok: Re: Failed in creating a polyhedron   (Yuefeng Qiu - 14 Aug, 2014)
 Add Message Add Message
to: "Failed in creating a polyhedron"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]