Message: "T" form Tube Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question "T" form Tube 

Forum: Geometry
Date: 27 Aug, 2013
From: Leonardo Ghizoni <Leonardo Ghizoni>

Hello,

I'm trying to build a tube in a "T" form, but getting some problems...

First, I'm trying to build it on ROOT (its faster to compile), but not sure if I'm getting it right.

Here's what I'm trying to do:

  TGeoBBox *Tube1 = new TGeoTube("Tube1",Inner_radius,Tube_radius,dim_X1);
  TGeoBBox *Tube2 = new TGeoTube("Tube2",Inner_radius,Tube_radius,dim_X1/2);
  TGeoBBox *Tube3 = new TGeoTube("Tube3",0,Inner_radius,dim_X1);
  TGeoBBox *Tube4 = new TGeoTube("Tube4",0,Inner_radius,dim_X1/2);

  TGeoRotation *r1 = new TGeoRotation("r1",0,90,0);
  r1->RegisterYourself();
  TGeoTranslation *t1 = new TGeoTranslation(0.,0.,dim_X1/2);
  t1->SetName("t1");
  t1->RegisterYourself();

  TGeoCompositeShape *Cs = new TGeoCompositeShape("Cs","(Tube1:r1+Tube2:t1)-(Tube1:r1*Tube3:r1)-(Tube2:t1*Tube4:t1)-(Tube3:r1+Tube4:t1)");
  TGeoVolume *comp = new TGeoVolume("COMP",Cs);
  comp->SetLineColor(kBlue);
  top->AddNode(comp,1);

The problem is that I cannot visualize it with OpenGL, and don't for sure what's the result.

Could someone help me, if possible??

Thanks in advance.

Leonardo.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: "T" form Tube   (John Apostolakis - 28 Aug, 2013)
(_ None: Re: "T" form Tube   (Leonardo Ghizoni - 24 Mar, 2014)
(_ None: Re: "T" form Tube   (John Apostolakis - 25 Mar, 2014)
 Add Message Add Message
to: ""T" form Tube"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]