Message: Re: Linking Fault while Compiling Caused by Using Xerces Version 3.1.1 for GDML File Use Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback Re: Linking Fault while Compiling Caused by Using Xerces Version 3.1.1 for GDML File Use 

Forum: Geometry
Re: Sad Linking Fault while Compiling Caused by Using Xerces Version 3.1.1 for GDML File Use (Alex Leatherland)
Date: 08 Jun, 2010
From: Gabriele Cosmo <Gabriele Cosmo>

Answer posted in Install-Configuration forum

-----------
On Tue, 08 Jun 2010 11:53:10 GMT, Alex Leatherland wrote:
> My apologies for the cross post:
> http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1289/1.html
> 
> I've installed the binaries for xerces-3.1.1 for use on windows with
> VC++ version 8.0 and I get the the following error when I trying to
> compile a program based on G02 I named GDML: -
> 
> >> Using granular libraries
> >> Linking GDML
> >> LINK : fatal error LNK1181: cannot open input file 'xerces-c.lib'
> >> make: *** [c:/g4work/bin/WIN32-VC/GDML] Error 2
> 
> The prior stages of compiling the program seem to happen correctly (no
> errors), the exact same error also occurs for the G02 example straight
> out of the box (although "GDML" is now "geotest").
> 
> The declaration of XERCESROOT has been checked and it points to the
> correct folder. It is likely in my view that the cause of this is that
> the library folder in the xerces-3.1.1 distribution does not have a .lib
> file by that name, the version as available to download for the website
> end the library file names in "_3.lib" or "_3D.lib" instead of simply
> ".lib".
> 
> Other information: - Geant4 was successfully built with GDML enabled, I
> am using geant4.9.2.p02 with cygwin and visual c++ 2005 express edition.
> - A large number of other programs have been built and ran using this
> build successfully that don't attempt use GDML.
> 
> thank you,
> 
> Alex Leatherland

 Add Message Add Message
to: "Re: Linking Fault while Compiling Caused by Using Xerces Version 3.1.1 for GDML File Use"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]