Message: Radioactive decay causes "Class G4AtomicDeexcitation is obsolete" warning Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Radioactive decay causes "Class G4AtomicDeexcitation is obsolete" warning 

Forum: Fast Simulation, Transportation & Others
Date: 12 Jan, 2012
From: Ioannis Sechopoulos <Ioannis Sechopoulos>

After moving to 9.5, if I try to run a simulation that involves the radioactive decay of an ion, e.g. Rb-82, once in while I get the following message:

 ********************************************************** 
 *                  W A R N I N G ! ! !                   * 
 ********************************************************** 
 *                                                        * 
 *  Class G4AtomicDeexcitation is obsolete. It has been   * 
 * discontinued and is going to be removed by next Geant4 * 
 *     release please migrate to G4UAtomDeexcitation.     * 
 *                                                        * 
 ********************************************************** 

(By the way, this message also has an error since the new class is called G4UAtomicDeexcitation, not G4UAtomDeexcitation.)

I tried the example rdecay02, and if I run the following set of commands:

PreInit> /run/initialize

Idle> /gps/position 0 0 0 
Idle> /gps/energy 0 keV   
Idle> /gps/particle ion   
Idle> /gps/ion 92 238 0  0
Idle> /run/beamOn 10    

this warning message also appears, so the problem doesn't seem to be my particular physics list, but with the RadioactiveDecay class that is still using an obsolete class. If I still use the RadioactiveDecay class, are my results still correct? Is there a way to get rid of this warning? Is there something that should be changed in RadioactiveDecay?

Thanks!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: Radioactive decay causes   (L.G. Sarmiento - 31 Jan, 2012)
(_ Idea: Re: Radioactive decay causes   (Vladimir Ivanchenko - 09 Feb, 2012)
 Add Message Add Message
to: "Radioactive decay causes "Class G4AtomicDeexcitation is obsolete" warning"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]